• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Crash on macOS Big Sur
#1
Bug 
Hi!

I was trying to use JK native app for macOS (1.0.3739) and it keeps cra$ng on launch.


Code:
Process:               JamKazam [2194]
Path:                  /Applications/JamKazam.app/Contents/MacOS/JamKazam
Identifier:            com.jamkazam.osx.client
Version:               1.0.3739
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           JamKazam [2194]
User ID:               501

Date/Time:             2021-01-30 16:18:17.559 +0000
OS Version:            macOS 11.1 (20C69)
Report Version:        12
Bridge OS Version:     3.0 (14Y908)
Anonymous UUID:        CF74D0BA-728E-9CAA-FD57-D6BB6E198BB9


Time Awake Since Boot: 3600 seconds

System Integrity Protection: enabled

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
Exception Codes:       KERN_INVALID_ADDRESS at 0x0000000000000086
Exception Note:        EXC_CORPSE_NOTIFY

Termination Signal:    Segmentation fault: 11
Termination Reason:    Namespace SIGNAL, Code 0xb
Terminating Process:   exc handler [2194]


Where's what I've done:
1 - Tried to create a new user and run JamKazam on it
2 - Check if there was any facebook related plugin on Internet Plug-ins (there wasn't)
3 - Tried with/out my audio device plugged in (I'm using a Focusrite 2i2 3rd)

I've also checked the logs from ~/Library/Logs/JamKazam.log and 

Code:
<W>2021-01-30T16:10:11 early init: mixer dialog
<W>2021-01-30T16:10:11 libpng warning: bKGD: invalid
<W>2021-01-30T16:10:11 libpng warning: bKGD: invalid
<W>2021-01-30T16:10:11 maxBitrateChanged iNetworkTestScore: 0 iVideoNetworkTestScore 0
<W>2021-01-30T16:10:11 maxBitrateChanged using hi fidelity bitrate for chat 64000 and music encode 320000
<W>2021-01-30T16:10:11 updateBitrateGroups 320000 64000 320000
<W>2021-01-30T16:10:11 SocketRPC: Removing old socket on "/Users/nunonelas/.JamKazamSocket"
<W>2021-01-30T16:10:11 creating video encode threads...
<W>2021-01-30T16:10:11 initAudioDelayFiFo ms: 120 delay1MsSamples: 48 maxFrameSize: 92160
<W>2021-01-30T16:10:13 Interface address: "fe80::aede:48ff:fe00:1122%en5" , AC:DE:48:00:11:22 , QFlags(0x1|0x2|0x4|0x20) , "en5"
<W>2021-01-30T16:10:13 Interface address: "fe80::478:bf71:a72b:2e58%en0" , 8C:85:90:58:0B:81 , QFlags(0x1|0x2|0x4|0x20) , "en0"
<W>2021-01-30T16:10:13 Interface address: "192.168.1.67" , 8C:85:90:58:0B:81 , QFlags(0x1|0x2|0x4|0x20) , "en0"
<W>2021-01-30T16:10:13 Interface address: "2001:818:d920:d100:8be:3bde:37c8:995d" , 8C:85:90:58:0B:81 , QFlags(0x1|0x2|0x4|0x20) , "en0"
<W>2021-01-30T16:10:13 Interface address: "2001:818:d920:d100:d5d5:db76:6831:ac9d" , 8C:85:90:58:0B:81 , QFlags(0x1|0x2|0x4|0x20) , "en0"
<W>2021-01-30T16:10:13 Interface address: "fe80::2821:c2ff:fee8:d7df%awdl0" , 2A:21:C2:E8:D7:DF , QFlags(0x1|0x2|0x4|0x20) , "awdl0"
<W>2021-01-30T16:10:13 Interface address: "fe80::2821:c2ff:fee8:d7df%llw0" , 2A:21:C2:E8:D7:DF , QFlags(0x1|0x2|0x4|0x20) , "llw0"
<W>2021-01-30T16:10:13 "My uiID: 1056396297"
<W>2021-01-30T16:10:13 serverConnectionConnected " --- New network port 52664 | 52664"
<W>2021-01-30T16:10:13 Interface address: "fe80::aede:48ff:fe00:1122%en5" , AC:DE:48:00:11:22 , QFlags(0x1|0x2|0x4|0x20) , "en5"
<W>2021-01-30T16:10:13 Interface address: "fe80::478:bf71:a72b:2e58%en0" , 8C:85:90:58:0B:81 , QFlags(0x1|0x2|0x4|0x20) , "en0"
<W>2021-01-30T16:10:13 Interface address: "192.168.1.67" , 8C:85:90:58:0B:81 , QFlags(0x1|0x2|0x4|0x20) , "en0"
<W>2021-01-30T16:10:13 Interface address: "2001:818:d920:d100:8be:3bde:37c8:995d" , 8C:85:90:58:0B:81 , QFlags(0x1|0x2|0x4|0x20) , "en0"
<W>2021-01-30T16:10:13 Interface address: "2001:818:d920:d100:d5d5:db76:6831:ac9d" , 8C:85:90:58:0B:81 , QFlags(0x1|0x2|0x4|0x20) , "en0"
<W>2021-01-30T16:10:13 Interface address: "fe80::2821:c2ff:fee8:d7df%awdl0" , 2A:21:C2:E8:D7:DF , QFlags(0x1|0x2|0x4|0x20) , "awdl0"
<W>2021-01-30T16:10:13 Interface address: "fe80::2821:c2ff:fee8:d7df%llw0" , 2A:21:C2:E8:D7:DF , QFlags(0x1|0x2|0x4|0x20) , "llw0"
<W>2021-01-30T16:10:13 ****** IPV6 address : "2001:818:d920:d100:d5d5:db76:6831:ac9d"
<W>2021-01-30T16:10:13 ****** IPV6 address : "2001:818:d920:d100:8be:3bde:37c8:995d"
<W>2021-01-30T16:10:13 initSockets link local IPV4 address "192.168.1.67"
<W>2021-01-30T16:10:13 ****** IPV4 address : "192.168.1.67"
<W>2021-01-30T16:10:13 initSockets link local IPV6 address "fe80::478:bf71:a72b:2e58%en0"
<W>2021-01-30T16:10:13 initSockets ****** SKIPPING LINK LOCAL IPV6 address protocol: "fe80::478:bf71:a72b:2e58%en0"
<W>2021-01-30T16:10:13 initSockets link local IPV6 address "fe80::aede:48ff:fe00:1122%en5"
<W>2021-01-30T16:10:13 initSockets ****** SKIPPING LINK LOCAL IPV6 address protocol: "fe80::aede:48ff:fe00:1122%en5"
<W>2021-01-30T16:10:13 initSockets link local IPV6 address "fe80::2821:c2ff:fee8:d7df%awdl0"
<W>2021-01-30T16:10:13 initSockets ****** SKIPPING LINK LOCAL IPV6 address protocol: "fe80::2821:c2ff:fee8:d7df%awdl0"
<W>2021-01-30T16:10:13 initSockets link local IPV6 address "fe80::2821:c2ff:fee8:d7df%llw0"
<W>2021-01-30T16:10:13 initSockets ****** SKIPPING LINK LOCAL IPV6 address protocol: "fe80::2821:c2ff:fee8:d7df%llw0"
<W>2021-01-30T16:10:13 serverConnectionConnected " --- post init network port 52664 | 52664"
<W>2021-01-30T16:10:13 serverConnectionConnected " --- New bound network IPV4 port 52664 "
<W>2021-01-30T16:10:13 serverConnectionConnected " --- New bound network IPV6 port 52664 "
<W>2021-01-30T16:10:13 QSqlQuery::prepare: database not open
<W>2021-01-30T16:10:13 gpuHwAccelDetect path: "/Applications/JamKazam.app/Contents/MacOS"
<W>2021-01-30T16:10:13 gpuHwAccelDetect checking -> "h264_badvideotoolbox"
<W>2021-01-30T16:10:13 gpuHwAccelDetect waiting for process to finish
<W>2021-01-30T16:10:13 gpuHwAccelDetect waitForFinished return true
<W>2021-01-30T16:10:13 gpuHwAccelDetect NO GPU HW Accel detected -> "h264_badvideotoolbox"
<W>2021-01-30T16:10:13 gpuHwAccelDetect checking -> "h264_videotoolbox"
<W>2021-01-30T16:10:13 gpuHwAccelDetect waiting for process to finish
<W>2021-01-30T16:10:13 gpuHwAccelDetect waitForFinished return true
<W>2021-01-30T16:10:13 gpuHwAccelDetect NO GPU HW Accel detected -> "h264_videotoolbox"
<W>2021-01-30T16:10:13 JKLatencyDialog fLoopbackLatencyOutputBoost: 10
<W>2021-01-30T16:10:13 JKLatencyDialog fLoopbackLatencyInputBoost: 10
<W>2021-01-30T16:10:13 init &&&&&&&&&&&&& url: "http://www.jamkazam.com/client" baseUrl: "http://www.jamkazam.com"
<W>2021-01-30T16:10:13 init baseUrlHttps: "https://www.jamkazam.com"
<W>2021-01-30T16:10:13 initializeBackingTracks "/Users/nunonelas/Music/JamKazam/BackingTracks/."
<W>2021-01-30T16:10:13 QSslSocket: cannot call unresolved function SSLv23_client_method
<W>2021-01-30T16:10:13 QSslSocket: cannot call unresolved function sk_num


my wild guess is that there's an issue with OpenSSL, so I rolled back to OpenSSL 1.0 
Code:
➜ ~ openssl version
OpenSSL 1.0.2m 2 Nov 2017

but I'm still having the same issue. What can I do here?

Thank you in advance!
  Reply
#2
I'm on Catalina, not Big Sur, and not having the issue you are facing.

I would have suggested doing what you already did with rolling back SSL.

Did you upgrade from 10.x to 11.1, or is this a clean install?

Are you running on Intel, or ARM CPU?

Did you have JK running before, using the same hardware you are running now?
  Reply
#3
(01-30-2021, 05:56 PM)Zlartibartfast Wrote: I'm on Catalina, not Big Sur, and not having the issue you are facing.

I would have suggested doing what you already did with rolling back SSL.

Did you upgrade from 10.x to 11.1, or is this a clean install?

Are you running on Intel, or ARM CPU?

Did you have JK running before, using the same hardware you are running now?
 Thank you for your answer!

I upgraded from 10.x. Considering that it would take me a huge while to make a clean install, this would be my last resort. 

Running on a Intel CPU (MacBook Pro (15-inch, 2017)).

Never got to run JK successfully. Newbie here! Smile
  Reply
#4
(01-30-2021, 11:01 PM)nnelas Wrote:
(01-30-2021, 05:56 PM)Zlartibartfast Wrote: I'm on Catalina, not Big Sur, and not having the issue you are facing.

I would have suggested doing what you already did with rolling back SSL.

Did you upgrade from 10.x to 11.1, or is this a clean install?

Are you running on Intel, or ARM CPU?

Did you have JK running before, using the same hardware you are running now?
 Thank you for your answer!

I upgraded from 10.x. Considering that it would take me a huge while to make a clean install, this would be my last resort. 

Running on a Intel CPU (MacBook Pro (15-inch, 2017)).

Never got to run JK successfully. Newbie here! Smile


>>>
I would consider more research and maybe getting dev support, before doing a rather drastic macOS re-install.
Running MBP with Catalina -> Big Sur upgrade myself, and have no issues running JamKazam now and before on Catalina neither.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)