• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Linux Application
#41
(02-15-2021, 09:11 PM)jamjam Wrote: You can download the Linux beta here - https://jamkazam-repo.s3.amazonaws.com/linux_build/jk_linux-01-10-2021.tar.xz   This beta does not have video support.
1. Expand the file change to the directory
2. Run the app by running ./run.sh
3. You can run with elevated realtime privilege which gives for steadier IO rate by modifying the run command to
sudo LD_LIBRARY_PATH=$APP_DIR/QtLibs:$APP_DIR/libs:$APP_DIR/QtPlugins:$APP_DIR/Libs:$LD_LIBRARY_PATH QT_QPA_PLATFORM_PLUGIN_PATH=$APP_DIR/QtPlugins/plugins ./JamKazam -rf

Updates to placed in the directory  https://jamkazam-repo.s3.amazonaws.com/linux_build/ 


Here is a way to list directory contents of this S3 bucket > https://github.com/prabhatsharma/s3-directorylisting (per https://stackoverflow.com/a/45825516/292408):

Quote:Just place the index.html file in the root of your s3 bucket and it will list all the root elements of s3 bucket.

  1. Make sure your bucket is public
  2. Make sure the everyone has rights to list bucket contents
  3. Make sure that CORS is enabled
No separate configuration required in this file.
  Reply
#42
How is progress going on the Linux client?
  Reply
#43
Thank you jamjam for working on this.

After a very long gestation, I finally completed updating my Linux PC. It didn't go smoothly but its good now.

I'm using latest Ubuntu Studio, which uses real-time Jack.
My PC uses an Intel i7 970 CPU (12 @ 3.2GHz)

I tried https://jamkazam-repo.s3.amazonaws.com/l...021.tar.xz

> ./run.sh
./run.sh: line 5: 30590 Illegal instruction (core dumped) ./JamKazam

I could not find the coredump.
Is there a debug option, another way of running it, or some way I could assist?

-------

I also tried jk_linux-12-31-2020.tar.xz - an earlier version given in the forum
The error message is slightly different
> ./run.sh
./JamKazam: error while loading shared libraries: libQt5WebSockets.so.5: cannot open shared object file: No such file or directory

----

Sorry my feedback has been so long coming.

Emma
  Reply
#44
Hi
Is anything happening with a client for Linux? I know that the users on Linux is a fraction of all the users but i think that this will change with so many other music softwares that works great for Linux (Ubuntu Studio, AV Linux, Reaper, Waveform etc).
/Patrik
  Reply
#45
I have the same questions. Is the Linux version under active development? Did they just drop the Beta and leave it untweaked? Does the Beta work? If not, has anybody tried running Jamkazam in a windows virtual machine like Virtualbox?
  Reply
#46
i am looking forward to trying out the Linux version
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)