• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Linux Application
#31
(02-07-2021, 12:15 PM)Dimitri Muskens Wrote:
(02-07-2021, 08:36 AM)graham Wrote:
(02-06-2021, 11:11 PM)Dimitri Muskens Wrote:
(02-06-2021, 09:06 PM)graham Wrote:
(02-06-2021, 08:33 PM)Dimitri Muskens Wrote: >>>
Hi Graham, just assuming you mean 2.26 & 2.27 ...

http://rpm.pbone.net/info_idpl_55698432_...4.rpm.html

Take it from there. Shouldn't be too crazy on deps. But ...

I'm a little worried about the "as far as I can tell" - why would you not know for sure? (Leap 15.2 also has glibc 2.26 per the release - they are rather slow)
I downloaded the glibc 2.7 rpm and tried to install it but it gave me some dangerous looking warnings that scared me enough that I didn't proceed with it. I could try it again and copy the warnings here if you think you could help me with it. I don't know enough about this subject to be able to predict the consequences.
Thank you for responding.

>>>
Again, assuming you mean 2.27 ??!!

How 'scary' can Linux get?
Here is the scary bit
And yes I mean 2.27 my apologies for the typo.

>>>
Nothing scary there ... .
Since you're playing with internet/p2p/audio-sw on the box, I assume it's not a heavily involved production environment(?)

Of course I don't know how actively your Suse box is involved in 'controlling' your network environment (running NIS/LDAP?), but many can do without Name Service Caching just fine. If you don't know, just manually stop the service and see what gives ... . (is it even running?)
Apart from that, did you try to resolve the issue with a newer version of nscd? (might you indeed need it on that box)
E.g. Leap 15.2 has a newer version of that package.

Are you comfortable enough in Linux to go beyond 'clicking in the GUI?'

Anything 'alarming' in the "141 more..." ?
I stopped nscd without any noticeable difference. The 141 more seem to include an awful lot of my development related things for graphics and audio like Magick++ , alsa and ancillary things like xml. I write c++ software for audio, MIDI and photographic applications and I don't want to break those.
Here is the full list
#### YaST2 conflicts list - generated 2021-02-07 14:18:29 ####

nscd-2.26-lp150.11.20.1.x86_64 requires glibc = 2.26, but this requirement cannot be provided
not installable providers: glibc-2.26-lp150.10.13.x86_64[openSUSE-Leap-15.0-1]
                  glibc-2.26-lp150.10.13.x86_64[repo-oss]
                  glibc-2.26-lp150.11.14.2.x86_64[repo-update]
                  glibc-2.26-lp150.11.17.1.x86_64[repo-update]
                  glibc-2.26-lp150.11.3.2.x86_64[repo-update]
                  glibc-2.26-lp150.11.6.120.x86_64[repo-update]
                  glibc-2.26-lp150.11.9.1.x86_64[repo-update]
    [ ] break nscd-2.26-lp150.11.20.1.x86_64 by ignoring some of its dependencies

    [ ] Following actions will be done:
deinstallation of nscd-2.26-lp150.11.20.1.x86_64
deinstallation of glibc-locale-base-2.26-lp150.11.20.1.x86_64
deinstallation of glibc-extra-2.26-lp150.11.20.1.x86_64
deinstallation of glibc-devel-2.26-lp150.11.20.1.x86_64
deinstallation of glibc-locale-2.26-lp150.11.20.1.x86_64
deinstallation of zlib-devel-1.2.11-lp150.11.1.x86_64
deinstallation of sqlite3-devel-3.28.0-lp150.2.9.1.x86_64
deinstallation of libxml2-devel-2.9.7-lp150.2.14.1.x86_64
deinstallation of libtiff-devel-4.0.9-lp150.4.16.1.x86_64
deinstallation of libstdc++6-devel-gcc7-7.4.1+r275405-lp150.12.1.x86_64
deinstallation of libsndfile-devel-1.0.28-lp150.3.3.1.x86_64
deinstallation of libpng16-devel-1.6.34-lp150.2.3.1.x86_64
deinstallation of liblcms2-devel-2.9-lp150.2.3.1.x86_64
deinstallation of libexpat-devel-2.2.5-lp150.2.6.1.x86_64
deinstallation of libbz2-devel-1.0.6-lp150.4.9.1.x86_64
deinstallation of glib2-devel-2.54.3-lp150.3.13.1.x86_64
deinstallation of gcc7-7.4.1+r275405-lp150.12.1.x86_64
deinstallation of dbus-1-devel-1.12.2-lp150.2.4.2.x86_64
deinstallation of alsa-devel-1.1.5-lp150.5.6.1.x86_64
deinstallation of ImageMagick-devel-7.0.7.34-lp150.2.41.1.x86_64
deinstallation of libexif-devel-0.6.21-lp150.2.2.x86_64
deinstallation of graphite2-devel-1.3.11-lp150.2.1.x86_64
deinstallation of fontconfig-devel-2.12.6-lp150.2.5.x86_64
deinstallation of patterns-base-x11_enhanced-20171206-lp150.15.9.1.x86_64
deinstallation of mtools-4.0.18-lp150.1.8.x86_64
deinstallation of man-2.7.6-lp150.3.8.x86_64
deinstallation of libyui-ncurses8-2.50.1-lp150.1.2.x86_64
deinstallation of libpng16-compat-devel-1.6.34-lp150.2.3.1.x86_64
deinstallation of libopenssl-1_1-devel-1.1.0i-lp150.3.25.1.x86_64
deinstallation of libqt4-devel-4.8.7-lp150.7.5.x86_64
deinstallation of libmng-devel-2.0.3-lp150.1.7.x86_64
deinstallation of freetype2-devel-2.9-lp150.2.1.x86_64
deinstallation of libxml++26-devel-2.40.1-lp150.1.8.x86_64
deinstallation of libxml++-devel-3.0.1-lp150.2.1.x86_64
deinstallation of libstdc++-devel-7-lp150.2.3.1.x86_64
deinstallation of gcc7-c++-7.4.1+r275405-lp150.12.1.x86_64
deinstallation of libraw-devel-0.18.9-lp150.2.6.1.x86_64
deinstallation of harfbuzz-devel-1.7.5-lp150.1.3.x86_64
deinstallation of pango-devel-1.40.14-lp150.2.3.1.x86_64
deinstallation of cairo-devel-1.15.10-lp150.3.3.1.x86_64
deinstallation of gtk2-devel-2.24.32-lp150.2.3.x86_64
deinstallation of glibmm2_4-devel-2.52.1-lp150.2.2.x86_64
deinstallation of gdk-pixbuf-devel-2.36.11-lp150.3.4.x86_64
deinstallation of atk-devel-2.26.1-lp150.2.4.x86_64
deinstallation of gcc-7-lp150.2.3.1.x86_64
deinstallation of libXft-devel-2.3.2-lp150.1.6.x86_64
deinstallation of libMagick++-devel-7.0.7.34-lp150.2.41.1.x86_64
deinstallation of yast2-4.0.104-lp150.2.16.1.x86_64
deinstallation of libyui-ncurses-pkg8-2.48.5.2-lp150.7.1.x86_64
deinstallation of autoyast2-installation-4.0.69-lp150.2.19.1.noarch
deinstallation of libyui8-3.4.0-lp150.1.8.x86_64
deinstallation of libopenssl-devel-1.1.0i-lp150.6.1.noarch
deinstallation of libclang5-5.0.1-lp150.7.3.1.x86_64
deinstallation of pcre-devel-8.41-lp150.4.15.x86_64
deinstallation of libsigc++2-devel-2.10.0-lp150.1.8.x86_64
deinstallation of libboost_headers1_66_0-devel-1.66.0-lp150.3.3.x86_64
deinstallation of gcc-c++-7-lp150.2.3.1.x86_64
deinstallation of yast2-users-4.0.11-lp150.2.10.1.x86_64
deinstallation of yast2-update-4.0.18-lp150.2.6.1.x86_64
deinstallation of yast2-tune-4.0.1-lp150.2.3.1.x86_64
deinstallation of yast2-sysconfig-4.0.1-lp150.2.3.1.noarch
deinstallation of yast2-support-4.0.1-lp150.2.3.1.noarch
deinstallation of yast2-sudo-4.0.0-lp150.2.3.1.noarch
deinstallation of yast2-storage-ng-4.0.221-lp150.2.28.1.x86_64
deinstallation of yast2-sound-4.0.1-lp150.2.3.1.x86_64
deinstallation of yast2-snapper-4.0.4-lp150.2.3.1.x86_64
deinstallation of yast2-services-manager-4.0.11-lp150.10.1.noarch
deinstallation of yast2-security-4.0.2-lp150.10.1.noarch
deinstallation of yast2-scanner-4.0.2-lp150.2.3.1.x86_64
deinstallation of yast2-samba-server-4.0.2-lp150.2.3.1.noarch
deinstallation of yast2-proxy-4.0.3-lp150.2.10.1.noarch
deinstallation of yast2-printer-4.0.2-lp150.2.3.1.x86_64
deinstallation of yast2-packager-4.0.74-lp150.2.19.1.x86_64
deinstallation of yast2-online-update-4.0.1-lp150.2.3.1.noarch
deinstallation of yast2-nis-client-4.0.3-lp150.2.3.1.x86_64
deinstallation of yast2-nfs-client-4.0.8-lp150.2.6.1.noarch
deinstallation of yast2-network-4.0.49-lp150.2.19.1.noarch
deinstallation of yast2-mail-4.0.4-lp150.2.3.1.noarch
deinstallation of yast2-iscsi-client-4.0.2-lp150.2.3.1.noarch
deinstallation of yast2-installation-4.0.74-lp150.2.15.1.noarch
deinstallation of yast2-firewall-4.0.34-lp150.7.1.noarch
deinstallation of yast2-country-4.0.23-lp150.2.6.1.x86_64
deinstallation of yast2-control-center-4.0.4-lp150.2.3.1.x86_64
deinstallation of yast2-bootloader-4.0.40-lp150.2.11.1.x86_64
deinstallation of yast2-apparmor-4.0.5-lp150.2.3.1.noarch
deinstallation of yast2-add-on-4.0.10-lp150.2.3.1.noarch
deinstallation of yast2-vpn-3.1.5-lp150.1.5.noarch
deinstallation of yast2-slp-4.0.0-lp150.1.1.x86_64
deinstallation of yast2-samba-client-4.0.1-lp150.1.1.noarch
deinstallation of yast2-pam-4.0.0-lp150.1.1.noarch
deinstallation of yast2-ntp-client-4.0.12-lp150.1.1.noarch
deinstallation of yast2-metapackage-handler-4.0.0-lp150.1.3.noarch
deinstallation of yast2-ldap-4.0.0-lp150.1.1.x86_64
deinstallation of yast2-journal-4.0.0-lp150.1.1.noarch
deinstallation of yast2-fonts-4.0.0-lp150.1.1.x86_64
deinstallation of yast2-auth-server-4.0.0-lp150.1.1.noarch
deinstallation of yast2-auth-client-4.0.0-lp150.1.1.noarch
deinstallation of patterns-yast-yast2_basis-20180409-lp150.3.1.x86_64
deinstallation of libyui-qt-pkg8-2.45.15.2-lp150.7.1.x86_64
deinstallation of yast2-ycp-ui-bindings-4.0.0-lp150.1.4.x86_64
deinstallation of libyui-qt8-2.49.2-lp150.1.1.x86_64
deinstallation of libyui-qt-graph8-2.44.6-lp150.1.11.x86_64
deinstallation of libqt5-creator-4.6.1-lp150.1.1.x86_64
deinstallation of libmysqlcppconn-devel-1.1.9-lp150.3.3.1.x86_64
deinstallation of libboost_regex1_66_0-devel-1.66.0-lp150.3.3.x86_64
deinstallation of libqt5-qtbase-common-devel-5.9.4-lp150.11.1.x86_64
deinstallation of libksuseinstall1-4.14.38-lp150.6.5.1.x86_64
deinstallation of yast2-online-update-frontend-4.0.1-lp150.2.3.1.noarch
deinstallation of yast2-control-center-qt-4.0.4-lp150.2.3.1.x86_64
deinstallation of yast2-ruby-bindings-4.0.6-lp150.1.1.x86_64
deinstallation of yast2-perl-bindings-4.0.1-lp150.1.1.x86_64
deinstallation of patterns-base-x11-20171206-lp150.15.9.1.x86_64
deinstallation of patterns-kde-kde_yast-20170319-lp150.7.1.noarch
deinstallation of libqt5-qtbase-devel-5.9.4-lp150.11.1.x86_64
deinstallation of libQt5Core-devel-5.9.4-lp150.11.1.x86_64
deinstallation of libkde4-4.14.38-lp150.6.5.1.x86_64
deinstallation of yast2-country-data-4.0.23-lp150.2.6.1.x86_64
deinstallation of yast2-transfer-4.0.0-lp150.1.1.x86_64
deinstallation of yast2-hardware-detection-4.0.0-lp150.1.1.x86_64
deinstallation of patterns-kde-kde_plasma-20170319-lp150.7.1.noarch
deinstallation of patterns-games-games-20170319-lp150.1.7.x86_64
deinstallation of patterns-desktop-imaging_opt-20170319-lp150.2.1.x86_64
deinstallation of patterns-desktop-imaging-20170319-lp150.2.1.x86_64
deinstallation of libqt5-qtdeclarative-devel-5.9.4-lp150.2.3.1.x86_64
deinstallation of libQt5Xml-devel-5.9.4-lp150.11.1.x86_64
deinstallation of libQt5Widgets-devel-5.9.4-lp150.11.1.x86_64
deinstallation of libQt5Test-devel-5.9.4-lp150.11.1.x86_64
deinstallation of libQt5Sql-devel-5.9.4-lp150.11.1.x86_64
deinstallation of libQt5PrintSupport-devel-5.9.4-lp150.11.1.x86_64
deinstallation of libQt5PlatformHeaders-devel-5.9.4-lp150.11.1.x86_64
deinstallation of libQt5OpenGL-devel-5.9.4-lp150.11.1.x86_64
deinstallation of libQt5Network-devel-5.9.4-lp150.11.1.x86_64
deinstallation of libQt5Gui-devel-5.9.4-lp150.11.1.x86_64
deinstallation of libQt5DBus-devel-5.9.4-lp150.11.1.x86_64
deinstallation of libQt5Concurrent-devel-5.9.4-lp150.11.1.x86_64
deinstallation of kdelibs4-core-4.14.38-lp150.6.5.1.x86_64
deinstallation of kdelibs4-4.14.38-lp150.6.5.1.x86_64
deinstallation of breeze4-style-5.12.8-lp150.2.3.1.x86_64
deinstallation of kplayer-0.7.2-lp150.2.17.x86_64
deinstallation of libkdepimlibs4-4.14.10-lp150.3.1.x86_64
deinstallation of libakonadi4-4.14.10-lp150.3.1.x86_64
deinstallation of kdebase4-workspace-libs-4.11.22-lp150.7.24.x86_64
deinstallation of kdebase4-runtime-17.08.3-lp150.5.15.x86_64
deinstallation of patterns-kde-kde_imaging-20170319-lp150.7.1.noarch
deinstallation of patterns-kde-kde-20170319-lp150.7.1.noarch
    [ ] do not install glibc-2.27-lp150.496.1.x86_64




#### YaST2 conflicts list END ###


Attached Files Thumbnail(s)
   
  Reply
#32
>>>
Hi Graham, there's very little in Linux that cannot be resolved but in some cases (OpenSuse being one) the distro in itself does not work in your favor (very slow in updating some packages). I can understand if you don't want to go there.
You mentioned possibly using another distro. Ubuntu Studio seems to be a favorite. If you want to stay in the RPM realm Fedora is pretty solid and knows specified spins (Jam) as well.


I will cuss a little now ... .
JKz runs just dandy on W10 & macOS10/11 ... 

Angel
  Reply
#33
(02-08-2021, 12:52 PM)Dimitri Muskens Wrote: >>>
Hi Graham, there's very little in Linux that cannot be resolved but in some cases (OpenSuse being one) the distro in itself does not work in your favor (very slow in updating some packages). I can understand if you don't want to go there.
You mentioned possibly using another distro. Ubuntu Studio seems to be a favorite. If you want to stay in the RPM realm Fedora is pretty solid and knows specified spins (Jam) as well.


I will cuss a little now ... .
JKz runs just dandy on W10 & macOS10/11 ... 

Angel
Dimitri, thanks very much for helping resolve whether I can do this or not. Looks like not. I have a spare drive and will install Ubuntu Studio on it and try that. At the moment I have to boot into Windows 8.1 to run JK and although it performs very well, I lose all the facilities I have in my Opensuse environment. Booting into Ubuntu should be a small step forward in that I will at least be able to access my Opensuse hard drive.
  Reply
#34
>>>
Just out of curiosity I tried Fedora Jam Live ('studio' distro spin)
That will also take some tweaking. For starters there are no dev packages. Can of course be easily added.
Not all needed libs are available (which can also be added)
Tried another online jam/collab platform. That also needed several deps resolved.
Being a quick test I didn't go forward.


Going to see what Ubuntu Studio is about now ... .

D./
  Reply
#35
You can download the Linux beta here - https://jamkazam-repo.s3.amazonaws.com/linux_build/jk_linux-01-10-2021.tar.xz   This beta does not have video support.
1. Expand the file change to the directory
2. Run the app by running ./run.sh
3. You can run with elevated realtime privilege which gives for steadier IO rate by modifying the run command to
sudo LD_LIBRARY_PATH=$APP_DIR/QtLibs:$APP_DIR/libs:$APP_DIR/QtPlugins:$APP_DIR/Libs:$LD_LIBRARY_PATH QT_QPA_PLATFORM_PLUGIN_PATH=$APP_DIR/QtPlugins/plugins ./JamKazam -rf

Updates to placed in the directory  https://jamkazam-repo.s3.amazonaws.com/linux_build/ 
  Reply
#36
(02-15-2021, 09:11 PM)jamjam Wrote: You can download the Linux beta here - https://jamkazam-repo.s3.amazonaws.com/linux_build/jk_linux-01-10-2021.tar.xz   This beta does not have video support.
1. Expand the file change to the directory
2. Run the app by running ./run.sh
3. You can run with elevated realtime privilege which gives for steadier IO rate by modifying the run command to
sudo LD_LIBRARY_PATH=$APP_DIR/QtLibs:$APP_DIR/libs:$APP_DIR/QtPlugins:$APP_DIR/Libs:$LD_LIBRARY_PATH QT_QPA_PLATFORM_PLUGIN_PATH=$APP_DIR/QtPlugins/plugins ./JamKazam -rf

Updates to placed in the directory  https://jamkazam-repo.s3.amazonaws.com/linux_build/ 
Excited that there is a linux client still in the works. The most recent version I see posted in this thread appears to be the 1/10 version ad I will start by trying that, but the updates directory does not appear to allow viewing. Is there any other way to access updates?
  Reply
#37
(02-15-2021, 09:11 PM)jamjam Wrote: Updates to placed in the directory  https://jamkazam-repo.s3.amazonaws.com/linux_build/ 

https://jamkazam-repo.s3.amazonaws.com/linux_build/  is empty and doesn't return a directory listing. 
  Reply
#38
(03-19-2021, 06:47 PM)ElijahLynn Wrote:
(02-15-2021, 09:11 PM)jamjam Wrote: Updates to placed in the directory  https://jamkazam-repo.s3.amazonaws.com/linux_build/ 

https://jamkazam-repo.s3.amazonaws.com/linux_build/  is empty and doesn't return a directory listing. 
Though the tarball linked earlier that is in that directory does work, so it must just be the way the server is configured. Unless that gets changed, we would need to know the filenames of any updates since we can't browse them.
  Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)