• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Zoom H4 - ASIO via USB2 - on WIN7
I finally managed to get some stability using a Zoom H4.
If these comments and tips help anyone - great!

Hardware setup:
  • on old H4 portable recorder (2 integrated microphones and 2 XLR line imputs)
  • an old laptop running WIN7
  • USB2 cable to link H4 to the laptop
  • headphones connected to H4 (well obviously)

H4 Firmware and Drivers
  • mine was running Ver-1 firmware which does not operate ASIO
  • it needs an upgrade to Ver2.4 which was downloaded from Zoom site
  • to upgrade, place the 'system.bin' file in the root directory of the SD card (that is inside H4)
  • power up H4 with an external power supply and while pressing the round MENU button down
  • ASIO driver is also downloaded from the Zoom site and installed on the laptop
  • here is a tip, if the driver does not install at first, try installing it in a compatibility mode
  • to do this > right click on the driver file > click Properties > select 'Compatibility' tab > select a compatibility mode e.g. XP or Vista
J-K Setup
  • if the H4 does not pass J-K latency test at first, click 'Tweaking ASIO Device Parameters' - a link below some notes on the right of the window
  • open ASIO Control Panel (can also be opened by MANAGE > AUDIO PROPERTIES > CONFIGURATIONS > ASIO...
  • adjust latency on ASIO to 10mSec (mine was set to 2msec and was failing J-K latency tests until I adjusted it to 10mSec)
  • at that stage everything was 'smooth sailing'
  • use 44kHz as the sampling rate
  • in 'next steps' of the J-K setup process, choose audio inputs (microphones in my case) and outputs (Line / Headphones)

That's it - hope it works for you too!
Cheers, Lex
I have question for all you clever people that have grasped J-K audio parameters:
- I am using Zoom H4 with its ASIO interface, USB2 into WIN7
- the link is working but latency is poor around 20mSec
- ASIO latency (on Zoom H4) is set to 5mSec
- on J-J 'Audio Booster' I try different settings for Audio Frame Size (currently 2.5mSec)
but it has no real effect on my in-session latency (around 20mSec)
- also in the 'Audio Booster' I played with the 'Outgoing Music Bitrate' (currently at 320Kbs) and again,
without noticeable effect
- I had better latency by using a simple clip-on mic in to the laptop before
- shouldn't using ASIO improve the latency
Please help me to understand and hopefully fix this...!
There may not be that many - or any - users of Zoom H4 on J-K but, here in short are the setup results that make it stable:
Zoom H4 with firmware Ver2.4, USB2 cable, via ASIO in to WIN7 and Jam-Kazam
- overall H4 works produces a disappointing results due to its ASIO driver
- the only stable working 'H4' setup for me was: 41KHz sampling rate, 5mSec Latency
- the same setup on J-K
- the main problem is the echo I hear from the time I play a note or a chord on my guitar to hearing it through the headphones
- headphones are connected to Line Out on 'H4' (changing it to Headphones Out, makes no difference to the dela-/echo)
- I call it 'Delay-Echo' as it is much too great to call it latency (it's about 200-300 mSec i.e. really bad
- tweaking H4 and J-K Audio Booster parameters invariably leads to J-K lock up and death and restart

- I think it is the ASIO driver (it comes from Zoom H4 site but no longer supported by Zoom)
- there may be an open source driver available that could make it work better
- but if there is one, I don't know it

Forum Jump:

Users browsing this thread: 1 Guest(s)