• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
help! Static and popping from my mic in all recordings
(09-28-2020, 08:59 AM)Fill Wrote: Any progress on this? I'd love to know. I get static/ popping on long notes particularly. I've tried about every combination of settings I think. Oddly, the ogg , compressed files I get afterwards don't have the clicking/ static but the wav and live stream has it; which is frustrating.

thanks for any help

MacBook Air. os 10.14 Scarlett 2.i.4
The ogg files are recorded on your local computer, then uploaded to your jk account after the fact.  There should be no stattic in the ogg tracks for the individual players, assuming they have their mic gain set properly.

The wav files are what are transmitted live in session, so these, and also the stream-mix files, may have the static. I also see a time lag between the individual player's ogg's.  If you have the patience to do it, you can get a better recording by pulling the personal ogg's into a DAW and adjusting the lag and volume balance yourself. By looking at the personal ogg's, you may also be able to tell which player(s) are clipping.  I should have mentioned, I only do mic audio, so have no idea what problems instruments create.

I think static can come from two places: gain too high (clipping) somewhere, or jitter in the process.  To attack a gain problem, first place I would look is your physical mic. Lots of wind players use fancy mics like the Blue Yeti  and Presonus Revelator, that have a separate gain control on the mic. I play clarinet, and have to keep that setting at about 2 on a scale of 1-10. It's something I set and never change. (This has nothing to do with JamKazam. )  To check gain outside of JK, you need a program that has a sound meter that shows green, yellow, or red. When you play as loud as possible, you should barely be in the red.

The equivalent in JK is the volume control in your audio inputs. People will say they can't hear you, and ask you to turn up your volume. If you do that in your audio inputs, you will start clipping and get static. You shouldn't change your audio inputs, you should have them change it in their personal mix. If they have you all the way up, explore the controls in manage > audio settings > framesize-booster+ > booster+. At least that's where it is as of june 2021. It keeps moving to different spots in the menu.

If the problem is jitter, there is a trade-off between jitter and latency.  To reduce latency, you are supposed to make the buffer size and audio framesize as small as possible. (I think these are equivalent settings.) buffer size is in the ASIO control panel, framesize is in manage > audio settings > framesize-booster+ > net+.  ASIO doesn't apply on MAC.

If you try to reduce the latency settings beyond the capability of your gear, you cause jitter. So you need to find the sweet spot between how much jitter you can tolerate to improve latency.

Messages In This Thread
RE: help! Static and popping from my mic in all recordings - by marilynfleming - 06-03-2021, 02:22 AM

Forum Jump:

Users browsing this thread: 1 Guest(s)